АвтоАвтоматизацияАрхитектураАстрономияАудитБиологияБухгалтерияВоенное делоГенетикаГеографияГеологияГосударствоДомДругоеЖурналистика и СМИИзобретательствоИностранные языкиИнформатикаИскусствоИсторияКомпьютерыКулинарияКультураЛексикологияЛитератураЛогикаМаркетингМатематикаМашиностроениеМедицинаМенеджментМеталлы и СваркаМеханикаМузыкаНаселениеОбразованиеОхрана безопасности жизниОхрана ТрудаПедагогикаПолитикаПравоПриборостроениеПрограммированиеПроизводствоПромышленностьПсихологияРадиоРегилияСвязьСоциологияСпортСтандартизацияСтроительствоТехнологииТорговляТуризмФизикаФизиологияФилософияФинансыХимияХозяйствоЦеннообразованиеЧерчениеЭкологияЭконометрикаЭкономикаЭлектроникаЮриспунденкция

ЭВМ программа

Читайте также:
  1. I. РАБОЧАЯ ПРОГРАММА
  2. V. ПРОГРАММА СОРЕВНОВАНИЙ
  3. Анализ ситуации 2000 года («Программа Грефа»)
  4. Антикризисная инвестиционная программа
  5. ВВОДНОГО ИНСТРУКТАЖА (ПРОГРАММА)
  6. Возникновение рабочего движения в России. Первые рабочие организации: их программа, значение.
  7. Всемирная программа действий в отношении инвалидов
  8. ГЛАВА 3. Константы в программах
  9. Государственная программа Российской Федерации
  10. Заочный сектор КДА. Программа для абитуриентов.
  11. Йога для беременных. Специальная программа для женщин, начиная с первого месяца беременности.
  12. Кадеты: образование партии, состав, программа, деятельность в годы I революции в России

 

Рассмотрим пример систематического составления алгоритма и программы для решения на ЭВМ достаточно сложной задачи обра­ботки данных.

Четвертая задача: Определить суммы элементов столбцов в матрице Anxm:

Приведем обобщенную постановку задачи и описание соответст­вующих общего метода решения и сценария диалога.

Постановка задачиСценарий

Дано: Матрица <N>´<M>

(a11 … a1N) < a11> ... < a1N >

(... ... ... ) - матрица Anxm ... ... ...

(aMl … aMN) < aMl > … < aMN >

Треб.: Суммы элементов:

(S1 ..., SN) - суммы столбцов <S1> ... <SN>

Где:

Si = аi1 + ...+ аiM

[i = (1… N)]

При: N > 0, М > 0.

 

Метод вычисленийПредставление данных

sk0 = 0 matr: ' матрица Anm:

sk1 = ak1+ sk1-1 data 3, 4

[1 = (1 ... M)] data I, 2, 3, 4

Sk = SkN data 0, 1, 2, 3

[k = (1 ... N)] data 0, 0, 1, 2

 

В предлагаемой ниже программе для представления матриц ис­пользуются операторыdata. В первом из этих операторов записаны размеры, а в каждом последующем операторе - строки матрицы:

АлгоритмПрограмма

алг «сумма строк матрицы» ' сумма строк матрицы

нач cls

чтение (п, т) . read n, m

если п > 0 и т > 0 то if N > 0 and М > 0 then

массив А[1:п,1:т] dim A (N,M)

массив S[1:n] dim S(n)

ввод-вывод_матрицы gosub vvod 'ввод-матрицы

суммирование_строк gosub sum 'суммирование

от k = 1 до п цикл for k= 1 to n

выв (s[k]) ? s[k]

кцикл next k

все end if

кон end

 

алг «суммирование строк» sum: 'суммирование строк

нач ' нач

от k = 1 до N цикл for k = 1 to n

s[k] := 0 s[k] = 0

от l = 1 до М цикл for I = 1 to m

s[k] := s[k] + A[k,l] s[k] = s[k] + a[k,l]

кцикл next I

кцикл next k

кон return

 

алг «ввод-вывод_матрицы» vvod: 'ввод-вывод_матрицы

нач ' нач

вывод («Матрица», N, «х», М) ? «Матрица»; m; «х»; m

от k = 1 до N цикл for k = 1 to n

от I = 1 до М цикл for l = 1 to m

чтение (A [k,l]) read A (k,l)

вывод (A [k,l]) ? A (k,l)

кцикл next 1

нов_строка ?

кцикл next k

кон return

 


1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43 | 44 | 45 | 46 | 47 | 48 | 49 | 50 | 51 | 52 | 53 | 54 | 55 | 56 | 57 | 58 | 59 | 60 | 61 | 62 | 63 | 64 | 65 | 66 | 67 | 68 | 69 | 70 | 71 | 72 | 73 | 74 | 75 | 76 | 77 |


При использовании материала, поставите ссылку на Студалл.Орг (0.006 сек.)